Only YOUng

ATL Server LIbrary (9.0.70425 Alpha) 버전 오류(atlsmtpconnection.h) 본문

VisualStudio

ATL Server LIbrary (9.0.70425 Alpha) 버전 오류(atlsmtpconnection.h)

Only Young - 수신 smok95 2010.07.28 12:42
크리에이티브 커먼즈 라이선스
Creative Commons License

visual studio 2008버전부터 atl server가 제외되면서 codeplex에서 다운로드 받아서 사용을 해야합니다.
그런데 codeplex에서 제공하는 atl server library에 문제가 있습니다.

atlsmtpcommection.h를 사용하여 메일전송을 하려고 하면 메일전송이 되지 않는데요..
문제는 atlmime.h 파일에 버그가 있어서 전송이 되지않는 문제입니다.

출처 : http://atlserver.codeplex.com/workitem/6897

해결방법은 atlmime.h 531라인의 *pdwLen=0; 부분을 주석처리하면 해결이 됩니다.

라이브러리가 알파버전이기는 하지만 예전에 이상이 없던 부분에서 오류가 발생하는것과 수정판이 나오지 않는 것이 의아스러긴 합니다.

저작자 표시 비영리 변경 금지
신고
0 Comments
댓글쓰기 폼